Jump to content

Recommended Posts

Questions and problems associated with installing and updating the game.

You can download the game on https://rf4game.com/download/. There you can also find the minimum and recommended system requirements.

Attention! The game does not work on 32-bit operating systems.
Attention 2! Unity no longer supports DirectX9. To play the game, you require DirectX10 or higher.

-------------------------------------------------- -------------------------------------------------- -------------------------------------------------- ----------------------------------------------

When handling game problems, be sure to stick to the template.

Problems with downloading and installing:

     1. Specify the operating system and its bit depth (32 or 64), which protection systems (antivirus and firewall) are used.

     2. Attach the  log file ... \ Games \ RF4 \ log.txt  

If the installed game does not start or closes with an error:

     1. Attach the  log file ... \ Games \ RF4 \ Game \ rf4_x64_Data \ output_log.txt  

     2. Describe in detail the problem, the sequence of actions that led to the problem (error), and attach a screenshot or send us a link to a video.

   3.  When dealing with connection issues, please open command line, insert the following "cmd /k ping rf4game.com /n 20 && pathping rf4game.com && tracert rf4game.com && pause", press Enter and wait for the results. Make a printscreen of the results and post it here.

-------------------------------------------------- -------------------------------------------------- -------------------------------------------------- ----------------------------------------------

For users who are faced with the problem of low game performance, frequent "freezes", "disconnects" or  "hangs", whose computers are equipped with the following listed video cards: 
AMD Radeon R5 235X, Radeon R5 235, Radeon R5 230, Radeon R5 220 Series Graphics
AMD Radeon ™ HD 8470, Radeon ™ HD 8350, Radeon ™ HD 8000 (D / G variants) Series Graphics
AMD Radeon ™ HD 7000 - HD 7600 (including A / D / G / M variants) Series Graphics
AMD Radeon ™ HD 6000 (including A / D / G / M variants) Series Graphics
AMD Radeon ™ HD 5000 (including M variant) Series Graphics
We are forced to report that AMD has declared the video card data obsolete. Update drivers for these video cards was suspended in 2015 and today they are no longer supported. Users who are keen on computer games, AMD advises to switch to the use of more modern video cards. 
The developers of RF4, for their part, will make efforts and try to eliminate the problems arising in the game due to the incorrect operation of the listed video cards.

 

Connectivity Issues:

If you are experiencing a connectivity issue please read and follow these steps:

Run a ping test - open command promt and enter the following - [ cmd /k ping rf4game.com /n 20 && pathping rf4game.com && tracert rf4game.com && pause ] hit Enter and wait for the results. See if you have any jumps in ping on the way to our servers and contact your provider to find out why you are having them.
 

Run a tracert test open command promt and enter the following - [ cmd /k tracert rf4game.com ] hit Enter and wait for the results. See if you have any interruptions on the route to the game server. Contact your provider to find out why you having them.

If the game has crashed or disconnected unexpectedly - 
DO NOT restart the game! Locate following file 
(C:\Users\<USERNAME>\AppData\LocalLow\Russian Fishing LLC\Russian Fishing 4\output_log.txt) and sent it to support@rf4game.com

 

If you experienced a Time Out error - please locate the following file (C:\Users\<USERNAME>\AppData\LocalLow\Russian Fishing LLC\Russian Fishing 4\NetLog_<COMPNAME>.txt) and send it to support@rf4game.com

 

 please include the output_log.txt located here: C:\Users\YOUR USERNAME \AppData\LocalLow\Russian Fishing LLC\Russian Fishing 4\output_log.txt

 

Only after taking these steps and if your issue isn't solved please provide screens from the test result and your communication with any tech team in this topic.

 

Also, please note that the game may be off line form time to time. Please check our "Announcement" section for more information before posting your issues.

  • Thanks 1

Share this post


Link to post
Share on other sites
17 minutes ago, elnando said:

I noticed a new update today, still stuck at 0.0% and downloads doesn't start at all, when it start the speed is 2bytes/s, what can i do?

Locate game folder.
Delete folder GAME and file RF4Launcher.conf
Launch RF4Launcher.exe

Share this post


Link to post
Share on other sites
On 10/25/2017 at 6:46 PM, nova747 said:

Had to do the " Delete folder GAME and file RF4Launcher.conf " last week and re download the entire 4.49gb now a power outage at home happen at 89%    rebooted pc re start launcher and is starting at 0% AGAIN!   I have over 9gb in RF4 EN  folder..the down-loader  cant see that it was 89% complete? Torrents are superposed to start where they left off

CANT even switch back to RU region to play the RU ver either  so I was told .

Sorry to hear the download went awry because of a power outage. And we understand your frustration. To fix it indeed there is nothing else left but to let the launcher run and download it all. 
You can switch back to RU. For that you need to contact Russian support: support@rf4game.ru  Mind that they only speak Russian, so you will have to contact them in Russian. 

 

On 10/29/2017 at 7:59 AM, nova747 said:

Well game finally downloaded and unpacked and I got to play the en ver yesterday for a bit.open the game today and launcher is stuck in a loop of downloading  12.2mb

Spoiler

 

after it downloads the 12.2mb gets to various stages of unpacking then starts the download over again

I tried the ru vers launcher and it too needed to download 12.2mb today but it worked perfectly

and is ready to play .

win 10 64bit

malware-bytes (disabled for download)

can't attach the log file ..not an accepted file type " Accepted file types gif, jpeg, jpe, jpg, png "

also I do not see a log file in \ Games \ RF4 \ Game \ rf4_x64_Data \ output_log.txt

just the one in \ Games \ RF4 \ log.txt  

Thanks , John

 

 

Please send an e-mail to: support@rf4game.com

Share this post


Link to post
Share on other sites
On 11/20/2017 at 4:11 AM, graiser said:

Do you guys have a asia or south east asia server? I'm currently experiencing huge delay and lagging which my input only response after almost a minute. This might cause by the server ping is too high because I don't experience this issues for any other online game.

Could you please do a tracert in the command line and post a screenshot of the outcome here?

 

On 11/20/2017 at 12:01 PM, graiser said:

Hi, Ladyofgames! Thanks for replying to my issues. I had been watching your videos about this game and decided to join this fishing comunity. By the way, can you tell me what should be my tracert target? I had type tracert in cmd but it gives me a few choice, not sure which should I type.

  Reveal hidden contents

tracert.png

 

put this in the line: cmd /k ping rf4game.com /n 20 && pathping rf4game.com && tracert rf4game.com && pause

 

On 11/21/2017 at 5:24 AM, graiser said:

is there anything I can do to reduce this ping problem...?

You'd have to talk to your internet provider about this.

Share this post


Link to post
Share on other sites
On 11/20/2017 at 3:50 PM, Duck47 said:

I tried to open game about an hour ago and the patch would not finish installing. I got the message..."Game content patch failed. Please try again." This was after it unpacked and was in the install mode. It appears at about the 50% install point.

On 10/19/2017 at 7:21 AM, RF4mod said:

Locate game folder.
Delete folder GAME and file RF4Launcher.conf
Launch RF4Launcher.exe

Please give this a try if you still have issues please let us know.

 

 

That worked. Thank you very much.

Share this post


Link to post
Share on other sites
1 hour ago, cns180784 said:

I've just had the same problem with the game patch content failed message. I deleted the Game folder and the .conf file and when launching the .exe it just proceeds to installing the game from scratch. Am i doing this right? do i have to reinstall the game?

cns180784, Yes that is the only fix right now.

Share this post


Link to post
Share on other sites
21 minutes ago, FisH LiPZZ said:

hi there, just a quick question! i keep getting rf4_x64exe stoped working. any help would be appreciated.

Hello Fish Lipzz,

When does your rf4_x64.exe stops working? Does it happen when updating the game or does it happen when you are playing?

Share this post


Link to post
Share on other sites
2 hours ago, teajay said:

every time i try and log inand play keeps saying ip address blocked 

Greetings Teajay,
It looks you entered in the wrong username/password for more than 3 times in a row. When that happens, your ip gets blocked for 15 minutes. Please enter your correct login details next time you try.

Edited by LadyofGames
Found the cause

Share this post


Link to post
Share on other sites
On 5-12-2017 at 6:37 AM, Khrev said:

What is the default install location of the game, including the directory? I uninstalled by using add/remove programs under Windows 7, but there was no uninstaller run, it just removed the game from the list of programs but gives no confirmation that it was actually uninstalled. I would like to know if this has left any files or folders behind...

Default would be C:\RF4\Game\

Share this post


Link to post
Share on other sites
1 hour ago, GazOr said:

 

  Reveal hidden contents

image.thumb.png.b2848f387fffe3abbf3d6fb70edf8e4d.png

Playing as usual and got lost connection to the server several times.
 

Greetings GazOr
First make sure you're not downloading or watching a stream/youtube. If not, then try restarting your router. It doesn't look like you've got package loss between your connection and our servers, but there might be a small issue with your internet. Our servers are working as usual.

Share this post


Link to post
Share on other sites
On 12/19/2017 at 10:06 AM, reyder9999 said:

Hi . I download the game and i can t open it .. wen i open with "Run Administrator" its not work .. and simple "Open" its not work .. any ideea ?

Greetings
Which windows version are you using, 32 or 64 bit?

 

On 12/19/2017 at 10:16 AM, reyder9999 said:

64 bit 

Please open up the game folder, delete the RF4Launcher.conf file and restart the launcher. Please, let us know if that didn't solve it.

 

On 12/19/2017 at 10:22 AM, reyder9999 said:

i don t have RF4Launcher.conf i download the game and its "RF4SetupEN.exe" and i open it and its not opening ..

Can you make sure it's not being blocked by an antivirus or firewall?

 

On 12/19/2017 at 10:42 AM, reyder9999 said:

NO , its not ativirus or firewall .. 

Please delete all RF4 content on your computer. Update all the drivers to make sure they are of the latest version. Turn off all anti-virus, malware etc. Download the game launcher once again and run it as admin.
Please let us know if this helps.

 

On 12/19/2017 at 1:14 PM, reyder9999 said:

I delete all and all my drivers its update and still not working ... I buy 7 day premium and now I lose ..

 

How are you launching the game? (desktop shortcut or from the RF4 folder)

 

On 12/19/2017 at 1:26 PM, reyder9999 said:
  Reveal hidden contents

 


I have been playing 2 days ago, then I deleted everything from the computer and today I downloaded it, download it and when I open it is loaded but nothing appears on the screen, I tried to open it with both "administrator" and " open "none works

 

Could you please attache a screenshot of the window when the game loads and (if any) an error you are getting.

 

On 12/19/2017 at 1:41 PM, reyder9999 said:

I dont have any error just its not starting the download I download on the site and after that its not work to open the pack 

And when you say you've deleted everything what do you mean by that? The game itself, OS, etc? How did you deleted it? Through control panel "uninstall" or some other way?

 

On 12/19/2017 at 1:46 PM, reyder9999 said:

I re install the windows 10 with all drivers , I try with firewall and antivirus I check the divers all good still not working to start download 

 

Could you please open the folder containing the game, make a screenshot and attache it here?

 

On 12/19/2017 at 1:57 PM, reyder9999 said:

its not working wit run and open too ..

 

  Reveal hidden contents

WP_20171219_19_54_41_Pro.jpg

 

Our tech support has sent you an email with new installer and instruction. Please check your email. Let us know if that helps.

 

OK , thx sir .

 

Share this post


Link to post
Share on other sites
11 hours ago, Althazar said:

i dont know if already mentioned (so many pages) 

i have downloaded this game, i have the correct *reccomended* but every time i click *Play* it keeps getting the error box *Failed to Run* - maybe because i installed before signing up? deleted from control pannel, signed up... re insatlling, so now it will work? (ran as admin previously also) 

EN version (as i live in UK)

Moved to correct topic. 
Which version of Windows are you using, 32 or 64 bit?

Share this post


Link to post
Share on other sites
1 hour ago, othmane said:

Hello ,  i updated my game yesterday and the game have ran  perfectly

Today i tried to lunch the game and that what i get  , the launcher unpack the game  and after that they show me this message

How to fix it please ?  :) 

  Reveal hidden contents

Capture.PNG

 

Hello @othmane,

If restarting the launcher not update correctly, you need to follow this steps:

Games content patch failed.
Exit the game.
Locate game folder.
Delete folder GAME and file RF4Launcher.conf
Launch RF4Launcher.exe

Share this post


Link to post
Share on other sites
On 21-12-2017 at 5:07 AM, Shindo said:

Why do i have to download the game every time you guys make an update?

your patches newer install correctly and i end up having to download the 2gb (5Gb) again and again. It now takes up more than 20 Gb !?The newest shooter games take only 40 to 50Gb.

And no, my installs and Pc's are not in the wrong as i have the game set up on 2 different machines!

If this happens constantly with each update, please wipe RF4 from your computer totally, then do a clean download and install of the game.

Share this post


Link to post
Share on other sites
On 12/23/2017 at 12:49 PM, Kristo said:

When there was a directx selection, my choice was dx9, then the game worked well. After the last big patch, the game crashes from time to time. It is terribly irritating.  My graphic card is amd radeon HD 6700.

 

  Hide contents

111.jpg

 

Hello Kristo,

Check if your video drivers are up to date and is your card intergrated or stand alone. Also, your video card might not have enough video memory to support the game. And make sure that you have Direct X 11, since Unity stopped supporting Direct X 9.

 

On 12/23/2017 at 3:53 PM, Kristo said:

Stand-alone graphics card, 4gb ram, dx 11. But like i said on dx 9 game was working well, dunno why now i have crashes. This happens when i leave the store or invetory, etc. Btw i have newest drivers.

Next time it happens, please do the following. Go to the folder where you installed the game and find the file output_log.txt By default it is in C:\RF4\Game\rf4_x64_Data\output_log.txt 
Send that file along with a short description to support@rf4game.com.

 

On 12/23/2017 at 4:16 PM, Kristo said:

I cant find this file.

 

  Reveal hidden contents

222.jpg

 

You will find it directly after the crash.

Share this post


Link to post
Share on other sites
On 12/24/2017 at 3:32 PM, cns180784 said:

I did wipe it off my pc completely the last time there was an update which failed to update and reinstalled the game, and now another update and i have to reinstall the game again. 

Try turning off your antivirus software when updating something might be getting corrupted during the update process also when you know that you have to do an update try to run the game as administrator see if that helps.

 

On 12/24/2017 at 5:58 PM, cns180784 said:

Cheers that seemed to work, at least for the 12mb update. But whats puzzled me is straight after it started downloading a 2gb update is that right? if so it seems running as admin has worked though its strange why there are two separate updates with one of them being tiny.

there were a few patches made to correct some small issues with the update and the launcher dose them in order as to not try to patch something that has not be installed yet.

Share this post


Link to post
Share on other sites
On 12/30/2017 at 8:05 AM, wiwi207 said:

win7 64,  intel core i7 6700k 4.ghz, 16gb ram, gtx 970, i updated my graphic card and always the same 

 

Please update your DirectX as well and let us know if that solved the issue.

 

On 1/1/2018 at 7:46 AM, Darren84 said:

Hello i have a problem im unable to fix after checking the forums. everytime i start my game it says unable to connect to update server.

ive tryd  Locate game folder.Delete folder GAME and file RF4Launcher.confLaunch RF4Launcher.exe.  ive also uninstall all virus protection wile updating. got latest drivers, reinstall game. i have 64bit os windows 10

Greetings 

Our apologies for the inconvenience. Could you please open up command and insert the following:

cmd /k ping rf4game.com /n 20 && pathping rf4game.com && tracert rf4game.com && pause

Press Enter, then make a screenshot of the results and post it here.

 

On 1/1/2018 at 8:26 AM, wiwi207 said:

not solved =( plz help i love this game cant play now =(

I'm sorry to hear that Wiwi. Could you please contact our support team at support@rf4game.com I'm afraid I've ran out of options for you to help you solve it. Our support team has more knowledge and they will help you as soon as they can.

Share this post


Link to post
Share on other sites
On 1/1/2018 at 9:09 AM, Darren84 said:

Thanks LadyofGames for quick reply. here is the screen shot you requested

Capture.PNG

Ah I just read you can't connect to update server. I read server.

Please use the administrator account on your computer, then start the launcher. It should be able to update then and allow you to play the game.

 

On 1/1/2018 at 9:30 AM, Darren84 said:

Still no luckeven after running as admin here is msg I get.

connect.PNG

Okay, please do the following step for step and in the given order:

- turn off your computer

- restart your router

- start the computer again and login to the administrator account of your computer

- disable your antivirus and firewalls

- go to the RF4 map and delete the file RF4Launcher.conf 

- right click on the launcher, and select Run as Administrator.

The launcher should now start again and download any remaining updates. After that, you should be able to play.

Let me know if this didn't work. 

 

 

On 1/1/2018 at 10:23 AM, Darren84 said:

unfortunately still no luck I followed your instructions but now getting different error. first id like to thank you for your help but I feel the need to say I've put over £120 over the last two weeks into this game as well as paying for premium so I really hope this can get fixed. 

crash.PNG

That's what we are here for :)

Can you try it starting the game again? The servers shouldn't be down. Please let me know if you still can't connect. 

 

On 1/1/2018 at 10:47 AM, Darren84 said:

Thanks :) I was able to get into game but unable to pick server en1/en2/en3 but after exiting game and trying again I'm now back to first error cant connect to update server and ive tryd 2 times now same msg

How many accounts are there on your computer? I mean, when you start it up, after the windows logo it asks you first to sign in before prompting to your desktop.

You need to login with the Administrator account and have your antivirus and firewall shut off.

 

 

On 1/1/2018 at 11:01 AM, Darren84 said:

I'm a single guy unfortunately hehe just the one account :)

 

Ow and i uninstalled my avast and shut down windows defender just for the update but no luck

Darren84,  can you please try and right click the game icon and run as administrator see where that goes.

 

it sounds like that something is blocking the connection out to the server when was the last time you were able to play successfully? 

 

On 1/1/2018 at 12:12 PM, Darren84 said:

just tryd delete the rf4launcher.conf and the  folder Game and run as admin. it lets me get to menu when I do it but I cant pick en1/en2/en3 and once I exit game and try go back in it dosnt work same problem "cant connect update server".

I think at this point you are going to need to uninstall the game and reinstall it from scratch because it should have re-downloaded the patches when you deleted the game folder 

 

On 1/1/2018 at 12:38 PM, Darren84 said:

just tryd to reinstall the game I clicked run it it downloaded launcher but then same msg cant connect to update server

ok you will have to email support@rf4game.com and see if they can help, It may also be an issue with your Isp not allowing the connection to the game there is something blocking you getting to the game update server and i am not sure where the issue is at the moment 

Share this post


Link to post
Share on other sites
2 hours ago, Morten748 said:

Hello!

My screen resolution was 2560x1440.

I did a reeset of grafik settings, but now i can not set the resolution back to 2560x1440

Anyone now how to fix this problem. Is it a bug ?

 

Morten748, Have you tried to set it to 2560 x 1440 in fullscreen mode? Last time i had this issue i had to set it in fullscreen mode then switch to windowed after.

Share this post


Link to post
Share on other sites
On 1/21/2018 at 2:00 PM, bobgoesfishing said:

Hi

Another problem here like this:

rf.png.f37e96f3c8ed270082656e00c5a2314e.png

Upon clicking "start", I'm greeted with this error message. And yes, I've read this thread and the deleting certain files-folders thing does not work, I've tried it 4 times already. I also tried reinstalling the game twice, and restarting my computer several times. Basically - nothing seems to work.

Any help is greatly appreciated.

-bob

can you please right click on the icon and run as administrator and see if that helps

 

 

On 1/21/2018 at 2:23 PM, bobgoesfishing said:

Did that. Still same error message.

Can you please email support@rf4game.com

Share this post


Link to post
Share on other sites
6 minutes ago, henrichsmith said:

i need to format the pc

can i copy the installation folder and avoid to download all once again?

thanks

 

I don't think it will work that way but you can try at worse case you will end up re-downloading it again.

Share this post


Link to post
Share on other sites
On 2/3/2018 at 4:27 PM, chefgott1 said:

My game won't update nor install, the loading screen gets stuck at 0%. I have not been able to play in weeks now and haven't been lucky with support responses either. Any ideas how to fix this issue?

chefgott1, What email address are you using to send to support?

you can start here first make sure to right click the launcher and run as administrator and disable any anti-virus software temporarily try the download again if that does not work they follow the instructions below.

 

 

On 2/3/2018 at 6:26 PM, chefgott1 said:

 

  Reveal hidden contents

image.thumb.png.82f6401fd498d603d0b20cea4033107c.png

 

chefgott1, Looking at you connection rate in the screenshot it appears that maybe your connection is being limited, Are you on a school connection or somewhere that might block a torrent style of download you may need to contact your Administrator it seems your connection might be blocked.

Share this post


Link to post
Share on other sites
On 2/9/2018 at 6:40 AM, HawkYs said:

Hey! I have a problem. Who can explain my how to fix it?

 

  Reveal hidden contents

Be pavadinimo.png

 

Hawkys,

Please try the following:

Locate game folder. Normally located In your C: dirve
Delete folder GAME and file RF4Launcher.conf
Launch RF4Launcher.exe

when running the launcher right click and run as administrator and temporarily disable your virus scanner.

Share this post


Link to post
Share on other sites

What should I do? When I trying to open the game, I got this problem.

Spoiler

fd8953032775b42e7f71a371065c67d9498.png

 

 

On 2/27/2018 at 4:51 AM, Gytautelis said:

Hello Rytazas1,

Go to your C:\Users\%username%\AppData\LocalLow\Russian Fishing LLC\Russian Fishing 4\Crashes folder and send files inside to support@rf4game.com

Done.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×