Jump to content
Sign in to follow this  
Qbat

Blank damage on Legacy Ti rods

Recommended Posts

Posted (edited)

Is it normal that I get almost 1% damage on the blanks on my Legacy Ti rods after fighting a 30kg Russian Sturgeon for 30 minutes? I a using straight mono 49kg line. Maybe I am using wrong line or something?

 

Here is a screenshot of the bank damage before fighting this fish:

Spoiler

1.jpg.afc279c7c2a83aab834624a28a0f438a.jpg

 

And here is a screenshot of the blank damage after fighting the fish:

Spoiler

2.thumb.jpg.d905151eb2e3d90843b8ba9ff8fbd2cd.jpg

 

This is my setup:

Spoiler

1020149271_01-01-202112-06-55.thumb.jpg.8ef18a293ff37b8b748c7fb5d137fbce.jpg

 

Edited by Qbat

Share this post


Link to post
Share on other sites

Another thing that might be interesting, I did not lock the reel during this fight.

 

And here is a screenshot of the fish I caught:

Spoiler

rf4_4.0.15763_20210101_120623.thumb.png.011102f3df8e58538472d0455024f209.png

 

Share this post


Link to post
Share on other sites
On 1/1/2021 at 12:37 PM, Qbat said:

Another thing that might be interesting, I did not lock the reel during this fight.

 

And here is a screenshot of the fish I caught:

  Reveal hidden contents

rf4_4.0.15763_20210101_120623.thumb.png.011102f3df8e58538472d0455024f209.png

thats not good. hope its just a bug

 

Share this post


Link to post
Share on other sites
On 1/2/2021 at 8:07 PM, CafrowL said:

 

 

The question is if it's a bug or me doing something wrong? Cause, 1% damage to the Blank for every 30kg fish is harsh.

Share this post


Link to post
Share on other sites

It does not appear to be a bug. Unfortunately, without being able to watch you bring the fish in, it's hard to say what you might be doing exactly to cause that sort of wear.

Share this post


Link to post
Share on other sites
1 hour ago, Qbat said:

Status today:

 

1568961967_05-01-202118-20-37.thumb.jpg.b3ed92bf78e9d22035a5ed5c054460d6.jpg

We have looked at your catch history and your breakages and have determined you are forcing the fish in. A 30 kilo sturgeon needs to be played, not horsed in. When you do this repeatedly, it will damage your rod blank. We can tell from the catch times that you are locking the brake and jerking fish in. Try to avoid this, yeah - you may get the fish a little faster, but by putting all the force on the rod and not using the friction brake you are rapidly damaging the blank.

Share this post


Link to post
Share on other sites

Ok, I get it, but is it normal having to buy new TI's every 9 month or so playing this game? 3 new TI's costs 60,000 silver.. I have replaced all my 3 TI's x3 times now, that is total 180,000 silver.

Already one of the TI's has 1,2% damage on the blanks... and I have only been carp fishing and not locking in any fish or dragging them in by the force of the rod...!

Edited by Qbat

Share this post


Link to post
Share on other sites

So. It's been almost 3 weeks since I bought 3 new TI rods and I have been fishing with my fortune 360 rods for over a week now. So in total I have only used the new TIs for maybe 1-2 weeks, and one of them already has 1,3% damage on the Blanks. I have not been locking the fish and only using lines under 40kg, most of the part I have been using mono line as well. I have even tried not to drag in the fish by the rods force and only trying to make my reels work.

 

Am I still doing something wrong?

 

image.png.697029c402b1da3b806df04f825041ff.png

Share this post


Link to post
Share on other sites
1 hour ago, Qbat said:

So. It's been almost 3 weeks since I bought 3 new TI rods and I have been fishing with my fortune 360 rods for over a week now. So in total I have only used the new TIs for maybe 1-2 weeks, and one of them already has 1,3% damage on the Blanks. I have not been locking the fish and only using lines under 40kg, most of the part I have been using mono line as well. I have even tried not to drag in the fish by the rods force and only trying to make my reels work.

 

Am I still doing something wrong?

 

image.png.697029c402b1da3b806df04f825041ff.png

Hello - please note this will be the last response you receive on this topic @Qbat You fish on average 10.75 hours a day. This is far more than most players. Fishing that much and focusing on bottom fishing is going to create wear on your favorite rods. This is NORMAL. Let me say that one more time. This is NORMAL. The more you fish, the more wear you create.  The rod blanks by design wear with use and are not designed to last forever.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Thank you for taking the time to answer me @Elwoodiath2 Appreciated. Yes I play the game several hours a day and I really enjoy it! I understand it's a hard question to answer 100% correctly and I get that. It's just that I have been playing this game for a few years now and when I see something different that is not what I am used to, I by default look into it more and try to figure out why. I was hoping to get some feedback not only from you admins but also players, if there was any tips or something to get less wear of my rods, rather than just not use them so much. By the way, I don't get fish every minute, 10.75 hours a day on average 😉 But again, thank you for the answer and I will not bother you with these questions anymore. I just have to get used to the amount of wear I get on the blanks and have now started fishing with some other rods instead of using TI's all the time. Thank you.

Edited by Qbat

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...